[Duvida] Erro em sistema

    Compartilhe

    StormAD
    Iniciante
    Iniciante

    Mensagens : 77
    Créditos : 12

    [Duvida] Erro em sistema

    Mensagem por StormAD em Sab Mar 28, 2015 4:48 pm

    Eu fiz a implantação desse sistema no meu CS:

    http://visionmakers.forumeiros.com/t99-sistema-de-vila

    O cliente compilou normalmente, mais quando fui compilar o
    servidor apresentou esse erro:



    Tudo que pedia para modificar no cliente e server side havia e substitui,
    exceto essa linha que não tinha no CS:

    Código:
    If frmMenu.optMale.Value Then
                        Call SendAddChar(frmMenu.txtCName, SEX_MALE, frmMenu.cmbClass.ListIndex + 1, newCharSprite, Vila)
                    Else
                        Call SendAddChar(frmMenu.txtCName, SEX_FEMALE, frmMenu.cmbClass.ListIndex + 1, newCharSprite, Vila)
                    End If

    mais encontrei essa e adicionei o termo "Vila" nela ficou assim:

    Código:
    If ConnectToServer(1) Then
                    Call SetStatus("Connected, sending character addition data...")
                    Call SendAddChar(sChar, newCharSex, newCharClass, newCharSprite, Vila)
                End If

    Isso no cliente side, e como havia falado o cliente side compilou sem erros e apresentou o problema no Server side no ModDataBase na linha 314 que é referente a spell (se não estou errado)

    OBS: Tem implantado o sistema de spell linear feita pelo Dooolly, testada e funcionou perfeitamente.


    _________________
    Eu Apoio Esse Projeto Very Happy

      Data/hora atual: Seg Dez 05, 2016 1:26 am