Suporte ao desenvolvimento de jogos!


    LM² - Level Equip

    Compartilhe
    avatar
    LeonMM
    Moderador Local
    Moderador Local

    Mensagens : 1932
    Créditos : 115

    Re: LM² - Level Equip

    Mensagem por LeonMM em Sab Set 02, 2017 12:35 pm

    @quimera555 escreveu:O meu esta dando um Erro

    Troque :
    Código:
     weapon_level = LMM_LevelEquip::WEAPON_LEVEL[$mouse.object.id]
        armor_level = LMM_LevelEquip::ARMOR_LEVEL[$mouse.object.id]
        if weapon_level != nil or armor_level != nil
          if weapon_level > $game_party.actors[0].level or armor_level > $game_party.actors[0].level
            $windows[:chat].write(LMM_LevelEquip::LVL_ERROR, 5)
            return
          end
        end 
    Por:
    Código:
    weapon_level = LMM_LevelEquip::WEAPON_LEVEL[$mouse.object.id]
        armor_level = LMM_LevelEquip::ARMOR_LEVEL[$mouse.object.id]
        if (weapon_level != nil and weapon_level > $game_party.actors[0].level) or (armor_level != nil and armor_level > $game_party.actors[0].level )
          $windows[:chat].write(LMM_LevelEquip::LVL_ERROR, 5)
          return
        end
    Obrigado por reportar o erro, quando ao erro anterior de não aparecer o requerimento no help, me contate via Discord.
    --
    Tópico atualizado galera, correção de bug.


    _________________
    Caso precise de suporte para algum dos meus scripts, me adicione no Discord: LeonMM#9597
    Scripts para NetMaker:

    Scripts Comuns:
    avatar
    quimera555
    Ocasional
    Ocasional

    Mensagens : 183
    Créditos : 46

    Re: LM² - Level Equip

    Mensagem por quimera555 em Seg Set 04, 2017 10:29 am

    No NetMaker 1.0.2 esta funcionado o "Nível Req" !


    _________________

      Data/hora atual: Qua Nov 22, 2017 9:07 pm