Suporte no desenvolvimento de jogos


    Problemas com script

    avatar
    Mathss
    Novato
    Novato

    Mensagens : 29
    Créditos : 2
    Cash : 0

    Problemas com script Empty Problemas com script

    Mensagem por Mathss em Ter Nov 29, 2011 6:32 pm

    Código:
    #Set Speed
        speed = parameters[7].split
        @enemies[event.id].temp_speed = speed[1].to_i

    Estou tendo problemas ai, exatamente na linha 368 onde tem:

    Código:
        speed = parameters[7].split

    Notas: Eu mudei recentemente o [ABS] Mr.Mo's ABS, pois como tinha feito alteraçãos em armas, eu tinha mudado apenas isto:

    Código:
    #Ranged Weapons
    RANGE_WEAPONS = {}
    # RANGE_WEAPONS[Weapon_ID] = [Character Set Name, Move Speed, Animation, Range, Animation Suffix]
    RANGE_WEAPONS[4] = ["Arrow", 5, 103, 5, 10, "_bow"]
    RANGE_WEAPONS[8] = ["Arrow", 5, 103, 5, 10]
    RANGE_WEAPONS[12] = ["Arrow", 5, 103, 10, 10]
    RANGE_WEAPONS[17] = ["Arrow", 5, 103, 10, 10]
    RANGE_WEAPONS[23] = ["Arrow", 5, 103, 10, 10]
    #Revólvers
    RANGE_WEAPONS[19] = ["Balas", 5.5, 102, 10, 12]
    RANGE_WEAPONS[22] = ["Balas", 5.5, 102, 10, 12]

    Para que as armas que eram de perto não sofresse esta alteração e mudei também para que as outras armas se corrigissem, assim os arcos ficavam sendo apenas os arcos e as pistolas apenas as pistolas, se precisar passar o contéudo completo:

    Se for preciso postar o Script todo eu posso passar por partes... Mas por ter mais de 2 mil linhas fica díficil...
    Nanzin
    Nanzin
    Membro de Honra
    Membro de Honra

    Mensagens : 1550
    Créditos : 252
    Cash : 0

    Problemas com script Empty Re: Problemas com script

    Mensagem por Nanzin em Ter Nov 29, 2011 7:23 pm

    Desculpe nao entendi muito bem o problema =/

    explique-se melhor!


    _________________
    Problemas com script Npvo

    Para Aqueles que gostam de Min e de meu Trabalho;
    Upem Meu Pet nao custa nda!!


    Pet:
    Problemas com script 5886250
    avatar
    Mathss
    Novato
    Novato

    Mensagens : 29
    Créditos : 2
    Cash : 0

    Problemas com script Empty Re: Problemas com script

    Mensagem por Mathss em Ter Nov 29, 2011 7:27 pm

    Eu modifiquei as armas de ranger, ai apareceu que tinha um erro na linha 368, que era:

    speed = parameters[7].split

    Foi no:

    [ABS] Mr. Mos ABS

    EDIT:

    Problemas com script 2gwi48z

    EDIT²:

    Ai na linha 368 que ta o erro...
    Nietore
    Nietore
    Lenda
    Lenda

    Medalhas : Problemas com script ZgLkiRU
    Mensagens : 849
    Créditos : 163
    Cash : 0

    Problemas com script Empty Re: Problemas com script

    Mensagem por Nietore em Ter Nov 29, 2011 7:34 pm

    Veio nem sei se é, mas pelo que vi o código que você modificou ta assim:
    Código:
    #Ranged Weapons
    RANGE_WEAPONS = {}
    # RANGE_WEAPONS[Weapon_ID] = [Character Set Name, Move Speed, Animation, Range, Animation Suffix]
    RANGE_WEAPONS[4] = ["Arrow", 5, 103, 5, 10, "_bow"]
    RANGE_WEAPONS[8] = ["Arrow", 5, 103, 5, 10]
    RANGE_WEAPONS[12] = ["Arrow", 5, 103, 10, 10]
    RANGE_WEAPONS[17] = ["Arrow", 5, 103, 10, 10]
    RANGE_WEAPONS[23] = ["Arrow", 5, 103, 10, 10]
    #Revólvers
    RANGE_WEAPONS[19] = ["Balas", 5.5, 102, 10, 12]
    RANGE_WEAPONS[22] = ["Balas", 5.5, 102, 10, 12]

    Presta atenção nesse comentário:
    Código:
    # RANGE_WEAPONS[Weapon_ID] = [Character Set Name, Move Speed, Animation, Range, Animation Suffix]

    Character Set Name "1"| Move Speed "2" | Animation "3" | Range "4" | Animation Suf
    fix "5"

    São 5 parâmetros
    E essa linha contem 6
    RANGE_WEAPONS[4] = ["Arrow", 5, 103, 5, 10, "_bow"]

    Então acho que se você apagar o ",_bow" deve resolver Razz

    Só uma suposição mesmo!


    _________________
    Problemas com script AIymW

    Eu poderia ser a pessoa mais agradavel do mundo! mas optei por ser eu mesmo.
    avatar
    Mathss
    Novato
    Novato

    Mensagens : 29
    Créditos : 2
    Cash : 0

    Problemas com script Empty Re: Problemas com script

    Mensagem por Mathss em Ter Nov 29, 2011 7:37 pm

    @Nietore escreveu:Veio nem sei se é, mas pelo que vi o código que você modificou ta assim:
    Código:
    #Ranged Weapons
    RANGE_WEAPONS = {}
    # RANGE_WEAPONS[Weapon_ID] = [Character Set Name, Move Speed, Animation, Range, Animation Suffix]
    RANGE_WEAPONS[4] = ["Arrow", 5, 103, 5, 10, "_bow"]
    RANGE_WEAPONS[8] = ["Arrow", 5, 103, 5, 10]
    RANGE_WEAPONS[12] = ["Arrow", 5, 103, 10, 10]
    RANGE_WEAPONS[17] = ["Arrow", 5, 103, 10, 10]
    RANGE_WEAPONS[23] = ["Arrow", 5, 103, 10, 10]
    #Revólvers
    RANGE_WEAPONS[19] = ["Balas", 5.5, 102, 10, 12]
    RANGE_WEAPONS[22] = ["Balas", 5.5, 102, 10, 12]

    Presta atenção nesse comentário:
    Código:
    # RANGE_WEAPONS[Weapon_ID] = [Character Set Name, Move Speed, Animation, Range, Animation Suffix]

    Character Set Name "1"| Move Speed "2" | Animation "3" | Range "4" | Animation Suf
    fix "5"

    São 5 parâmetros
    E essa linha contem 6
    RANGE_WEAPONS[4] = ["Arrow", 5, 103, 5, 10, "_bow"]

    Então acho que se você apagar o ",_bow" deve resolver Razz

    Só uma suposição mesmo!

    Vou testar...

    EDIT:

    Não deu certo...

    Se bem me lembro este "_bow" já estava ai a muito tempo...

    Deve ter sido na parte 368 mesmo, já que fui informado disto...


    Última edição por Mathss em Ter Nov 29, 2011 7:44 pm, editado 1 vez(es)


    _________________
    Problemas com script Ke7qki
    Nanzin
    Nanzin
    Membro de Honra
    Membro de Honra

    Mensagens : 1550
    Créditos : 252
    Cash : 0

    Problemas com script Empty Re: Problemas com script

    Mensagem por Nanzin em Ter Nov 29, 2011 7:40 pm

    é verdade! tem 6 parametros!


    _________________
    Problemas com script Npvo

    Para Aqueles que gostam de Min e de meu Trabalho;
    Upem Meu Pet nao custa nda!!


    Pet:
    Problemas com script 5886250
    LeonM²
    LeonM²
    Moderador Local
    Moderador Local

    Mensagens : 1790
    Créditos : 139
    Cash : 0

    Problemas com script Empty Re: Problemas com script

    Mensagem por LeonM² em Ter Nov 29, 2011 7:50 pm

    isso ai da linha é dos inimigos e ñ das armas. vc adicionou algum inimigo?


    _________________
    Caso precise de suporte para algum dos meus scripts, me adicione no Discord: LeonM²#9597
    avatar
    Mathss
    Novato
    Novato

    Mensagens : 29
    Créditos : 2
    Cash : 0

    Problemas com script Empty Re: Problemas com script

    Mensagem por Mathss em Ter Nov 29, 2011 7:50 pm

    Problemas com script 10culq8

    Se esta imagem puder ajudar ta ai...


    EDIT:

    Leon Mega Maker escreveu:isso ai da linha é dos inimigos e ñ das armas. vc adicionou algum inimigo?

    Opa, fiz sim, usei o valor ID 2 e coloquei no mapa, se este for o problema...

    EDIT²:

    ABS
    ID 2
    Behavior 3
    Sight 8
    Sound 9
    ClosestEnemy false
    HateGroup [0]
    Tigger 0


    Última edição por Mathss em Ter Nov 29, 2011 7:54 pm, editado 2 vez(es) (Razão : Li a mensagem só depois...)
    LeonM²
    LeonM²
    Moderador Local
    Moderador Local

    Mensagens : 1790
    Créditos : 139
    Cash : 0

    Problemas com script Empty Re: Problemas com script

    Mensagem por LeonM² em Ter Nov 29, 2011 7:52 pm

    mude o valor para 0 ou 1 e teste


    _________________
    Caso precise de suporte para algum dos meus scripts, me adicione no Discord: LeonM²#9597
    avatar
    Mathss
    Novato
    Novato

    Mensagens : 29
    Créditos : 2
    Cash : 0

    Problemas com script Empty Re: Problemas com script

    Mensagem por Mathss em Ter Nov 29, 2011 7:56 pm

    Leon Mega Maker escreveu:mude o valor para 0 ou 1 e teste


    Deu certo...

    Obrigado a todos pela ajuda, "+" para todo mundo...

    EDIT:

    Alquém tem um tutorial sobre como adicionar monstros sem ter este problema? Se este tópico já tiver fechado, pode ser por MP...

    EDIT²:

    Agora é outro erro:

    Código:
    #==============================================================================
    # ** Auto Save
    #------------------------------------------------------------------------------
    # By Marlos Gama
    #==============================================================================

     def salvar
      name = Network::Main.name
      char_id = $char_id
      file = File.open("Jogadores/#{name}-#{char_id}.rxdata", "wb")
        characters = []
        for i in 0...$game_party.actors.size
          actor = $game_party.actors[i]
          characters.push([actor.character_name, actor.character_hue])
        end
        Marshal.dump(characters, file)
        Marshal.dump(Graphics.frame_count, file)
        $game_system.save_count += 1
        $game_system.magic_number = $data_system.magic_number
        Marshal.dump($game_system, file)
        Marshal.dump($game_switches, file)
        Marshal.dump($game_variables, file)
        Marshal.dump($game_self_switches, file)
        Marshal.dump($game_screen, file)
        Marshal.dump($game_actors, file)
        Marshal.dump($game_party, file)
        Marshal.dump($game_troop, file)
        Marshal.dump($game_map, file)
        Marshal.dump($game_player, file)
        Marshal.dump($ABS, file)
        Marshal.dump($distribuir_pontos, file)
        Marshal.dump($genero, file)
        Marshal.dump($guild_name, file)
        Marshal.dump($guild_position, file)
        Marshal.dump($flag, file)
        Marshal.dump($guild_points, file)
        Marshal.dump($guild_lider_name, file)
        Marshal.dump($item_carregado, file)
        Marshal.dump($carregou_item, file)
        Marshal.dump($item_carregado_2, file)
        Marshal.dump($carregou_item_2, file)
        Marshal.dump($item_carregado_3, file)
        Marshal.dump($carregou_item_3, file)
        Marshal.dump($item_carregado_4, file)
        Marshal.dump($carregou_item_4, file)
        Marshal.dump($level_info, file)
        Marshal.dump($arma_n, file)
        Marshal.dump($escudo_n, file)
        Marshal.dump($capa_ac, file)
        Marshal.dump($bota_ac, file)
        Marshal.dump($amuleto_ac, file)
        Marshal.dump($luva_ac, file)
        file.close
      end

    Pelo que vi era na linha 27 do autosave...

    Nome do Script: [ACT] Auto Save

    EDIT³:

    Problemas com script 209ow9l

    Conteúdo patrocinado

    Problemas com script Empty Re: Problemas com script

    Mensagem por Conteúdo patrocinado


      Data/hora atual: Sex Nov 22, 2019 4:34 am